Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 11, 2026 - 01:30 EST
Scheduled
To continue providing a stable and high-performing experience, we’ll be conducting scheduled maintenance on the Shulcloud platform.
When: Wednesday, February 11, 2026 Starting at 01:30 AM Eastern (US)
Expected Downtime: 1 hour
What to Expect: Shulcloud will undergo a scheduled update that includes approximately one hour of downtime. During this window, the platform will be temporarily unavailable while we complete important behind‑the‑scenes improvements. We’re making these updates to keep Shulcloud faster, more reliable, and easier to use. Thank you for your patience while we work to enhance your experience.
If you have any questions or concerns, please reach out to our support team at questions@shulcloud.com. We’re always happy to help.
Thank you for being a valued part of the Shulcloud community!
Posted Feb 09, 2026 - 10:20 EST
This scheduled maintenance affected: ShulCloud Application (ShulCloud Portal).