Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 14, 2026 - 22:00 EDT
Scheduled
Upcoming Scheduled Maintenance Notice To continue providing a stable and high-performing experience, we’ll be conducting scheduled maintenance on the Shulcloud platform.
What to Expect: We are not anticipating any downtime during this maintenance window, and Shulcloud is expected to remain available throughout the update. However, some users may experience brief, minor disruptions while improvements are being applied behind the scenes.
Every update we make is designed to enhance your experience, making Shulcloud faster, more reliable, and easier to use.
If you have any questions or concerns, please reach out to our support team at questions@shulcloud.com. We’re always happy to help.
Thank you for being a valued part of the Shulcloud community!
Posted Apr 14, 2026 - 13:05 EDT
This scheduled maintenance affected: ShulCloud Application (ShulCloud Portal).