Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 17, 2026 - 20:00 EST
Scheduled
Upcoming scheduled maintenance notice
To continue providing a stable and high-performing experience, we’ll be conducting scheduled maintenance on the Shulcloud platform.
When: Tuesday, February 17, 2026 Starting at 10:00 PM Eastern (US)
Expected Downtime: None Expected
What to Expect: There will be no downtime during this update! Shulcloud will remain fully available while we implement improvements behind the scenes. You can continue using the platform as usual without any interruption. Every update we make is designed to enhance your experience, making Shulcloud faster, more reliable, and easier to use.
If you have any questions or concerns, please reach out to our support team at questions@shulcloud.com. We’re always happy to help.
Thank you for being a valued part of the Shulcloud community!
Posted Feb 15, 2026 - 16:10 EST
This scheduled maintenance affected: ShulCloud Application (ShulCloud Portal).