ShulCloud Accessibility Issues

Incident Report for shulware

Resolved

This incident has now been resolved and we apologize for the inconvenience.
Posted Mar 12, 2025 - 11:45 EDT

Investigating

We are currently investigating issues regarding the inability to load your ShulCloud sites. Our team is aware of the issue and working to restore access as quickly as possible. We will share additional information as it becomes available.
Posted Mar 12, 2025 - 11:16 EDT
This incident affected: ShulCloud Application (ShulCloud Portal).